If the "Get Weight" button for the scale is disabled, grayed out, or not working, follow these troubleshooting steps.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
The "Get Weight" button for the scale is disabled, grayed out, or not working.
Cause
- The scale may not be connected to the computer.
- DeviceHub may not be connected or activated.
- The scale may need to be zeroed.
Resolution
- Solution 1: Make sure that you are using a compatible scale
- Solution 2: Install or reinstall DeviceHub
- Solution 3: Make sure that your scale is installed, connected, and online
- Solution 4: Reconnect DeviceHub
- Solution 5: Activate DeviceHub
- Solution 6: Zero the scale
Solution 1: Make sure that you are using a compatible scale
Solution 2: Install or reinstall DeviceHub
- If DeviceHub is not installed, install it. If it is already installed, reinstall it. For instructions, see: Note: If a message appears during the installation process stating that DeviceHub is already installed, click OK to remove the previous version, then click Uninstall. Once the process is complete, click Finish.
- Close and reopen your web browser.
- Sign back in to PitneyShip, PitneyShip Pro, or PitneyShip Enterprise.
- Go to Settings > My Devices.
- Wait for the DeviceHub activation to occur. Two separate messages should appear in the upper right corner of your browser window.
- The first message says "Registering DeviceHub to your computer... This will take a few moments."
- The second message says "DeviceHub is successfully registered. Your printer and scale are now connected."
- The first message says "Registering DeviceHub to your computer... This will take a few moments."
- After the second message disappears, wait a few moments. After a brief time, the list of printers and scales should be displayed on the My Devices page.
- If the "Get Weight" button still does not work, proceed to solution 3.
Solution 3: Make sure that your scale is installed, connected, and online
- In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, go to Settings > My Devices.
- Verify that the scale shows an Online or Idle status.
- If the scale is not listed, or the status is Offline or Other, check the following:
- Make sure that the scale is installed on the computer.
- In Windows, go to Settings > Devices > Printers and make sure that the scale is present and online.
- On Mac, go to Apple menu > About this Mac > More Info (Ventura OS users only) > System Report > USB. Make sure that the scale is present under USB 3.0 or 3.1 and is online.
- Verify that the scale is turned on and awake.
- Verify that the scale is on and is connected correctly to the computer.
- Once the scale is connected and online, try to print again.
Solution 4: Reconnect DeviceHub
- Right-click on the DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar and choose Reconnect.
- Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
Solution 5: Activate DeviceHub
- Select Settings > My Devices.
- Select Activate DeviceHub.
- Once DeviceHub is registered successfully, select Close.
- Go back to the My Devices page and select Refresh.
Solution 6: Zero the scale
- Select Settings > My Devices.
- Find your scale in the list of connected devices.
- Click on the zero scale arrow.
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