Learn how to resolve PC Meter Connect connection issues.
Products affected: DM60™ (K722), DM110i™, DM160i™, DM220i™ (PR20), DM300M™, DM400M™, DM475M™ (G922, RG9224M, SG922)
Issue
Your franking machine cannot download postage, download software or perform a rate update while connected using PC Meter Connect.
Cause
Either the franking machine cannot communicate with PC Meter Connect, or PC Meter Connect cannot connect to the Pitney Bowes Data Centre.
Resolution
- Solution 1: Check your network configuration
- Solution 2: Try restarting your franking machine
- Solution 3: Check to ensure that you have the latest version of PC Meter Connect
- Solution 4: Check the connection between your franking machine and your computer
- Solution 5: Change the PC Meter Connect Internet options
Solution 1: Check your network configuration
- Make sure that your network is configured to allow the franking machine to communicate with the Pitney Bowes Data Centre.
If your issue is not resolved, try Solution 2.
Solution 2: Try restarting your franking machine
- Unplug your power cord from the back of your franking machine.
- Unplug your USB cable from the back of your franking machine.
- Wait 30 seconds.
- Plug your USB cable back into your franking machine. Make sure that the other end of the USB cable is plugged into your computer.
- Plug your power cord back into your franking machine. You should see the message Meter Detected.
If your issue is not resolved, try Solution 3.
Solution 3: Check to ensure that you have the latest version of PC Meter Connect
- The latest version of PC Meter Connect desktop application is 05.00.0081.
- Right-click on the PC Meter Connect system tray icon.
- Select About PC Meter Connect.
- If you do not have the latest version, uninstall and reinstall it:
- Right-click on the system tray icon and select Exit.
- Unplug your USB cable from your franking machine and your computer.
- Unplug your power cord from the back of your franking machine.
- Select Windows Start > Control Panel > Programs and Features.
- Select PC Meter Connect and select Uninstall.
- Download and install the latest version of PC Meter Connect.
- Right-click on the system tray icon and select Exit.
- If PC Meter Connect was reinstalled, restart your franking machine and your computer:
- Unplug your power cord.
- Wait one full minute.
- Plug the power cord directly back into a wall outlet. Check that the wall outlet is working correctly.
- Restart your computer by closing all open programs and selecting Shut down from the Windows Start menu.
- Once your computer has completely shut down, turn it back on.
- Attempt your connection again.
If your issue is not resolved, try Solution 4.
Solution 4: Check the connection between your franking machine and your computer
- Unplug your USB cable from the back of your franking machine, then firmly reconnect it.
- Unplug your USB cable from your computer, then firmly reconnect it.
- If you are using a USB hub, remove your cable from the USB hub and plug it into a USB port on your computer.
- Retry your connection.
- If your connection still fails, try moving your USB cable to a different USB port on your computer.
Recommended: Use a USB port on the back of your computer.
If your issue is not resolved, try Solution 5.
Solution 5: Change the PC Meter Connect Internet options
- Right-click the PC Meter Connect icon in the system tray.
- Select Internet Settings.
- Toggle the settings for HTTP Transfer Protocol Method and Protocol. After you make a change, select OK and retest. Try all available combinations. Some options may be disabled depending on the type of franking machine you are using
- HTTP Transfer Protocol Method: Determines whether the data transferred is chunked or non-chunked. Try changing this first, as many firewalls will not allow chunked data by default.
- Protocol: Determines which transfer protocol is used for the data transfer. Many firewalls do not allow FTP.
*Important: Mac, Linux and other non-Windows operating systems are not currently supported. FIPS mode is not currently supported on Windows 10.
If you need further assistance, please contact us.
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